MDS HttpWebRequest WebException RemoteServer issue

Here is a small description of the issue:

I have in my box Windows Server 2012 64-bit, SQL Server 2012 SP1 64-bit and SharePoint 2013.

After installing and configuring MDS on my server, I can go to the web app’s home page but if I click on the Explorer (or pretty much anything running SilverLight), I get the following error:

MDS_HttpWebRequest_WebException_RemoteServer

 

Then I downloaded and install the Excel Add-in for Excel 2013, but when I try to connect to the server, I’m getting this error:

MDS_Add_In_Excel

 

After hours of more research, and lots of patience I finally was able to solve a very weird issue with Master Data Services.

It turns out that that for some odd reason, the applicationHost.config file located in the windows/system32/inetsrv/config folder  was missing a XML tag for the MDS ‘service’.

1) Make sure you have all the MDS Web Application requirements installed on your server: http://msdn.microsoft.com/en-us/library/ee633744.aspx

2) Make sure you created your site with the MDS Configuration Manager and that you in fact can browse the Home Page.

3) You need to have Admin permissions and edit the windows/system32/inetsrv/config/applicationHost.config file to make sure it contains the following tags:

<location path="MDS">
 <system.webServer>
  <security>
   <authentication>
    <digestAuthentication enabled="false" />
    <basicAuthentication enabled="false" />
    <anonymousAuthentication enabled="false" />
    <windowsAuthentication enabled="true" />
   </authentication>
  </security>
 </system.webServer>
</location>

<location path="MDS/Service">
 <system.webServer>
  <security>
   <authentication>
    <basicAuthentication enabled="false" />
    <anonymousAuthentication enabled="true" />
    <windowsAuthentication enabled="true" />
   </authentication>
  </security>
 </system.webServer>
</location>

If I have to guess what exactly caused the issue, I’ll say that the ‘Service’ tag gets created the first time you create a site, so if you for any reason end up deleting or creating another site, IIS is actually not updating this file. But, that’s just my guess.

18 thoughts on “MDS HttpWebRequest WebException RemoteServer issue

  1. Klas says:

    I also got this error message recently. Turned out i had less than 5% free memory. After freeing up some RAM MDS started working properly.

  2. Gabriel says:

    I got the same error by starting Integration Management. Your solutions works. I think you guess right, cause I recreated the site serval times and “”MDS/Service”” was the missing part. Thanks

  3. Lisa M says:

    Everything is setup as you mentioned. I am the only user having this issue. The others do not get this error. The Admin removed me completely and re-added me and I still get the web error. I even tried from another PC and get the issue. Almost like a profile setting

    • Alex Gonzalez says:

      Ok, I am getting a feeling that it could be a DNS issue, meaning that your internet browser is trying to communicate with an internal network but only has access to external. Get the server name or ip address of the MDS server and try to ping it.
      When you try to reach the mds home page, does it actually load? or what error do you get?

  4. Alex Gonzalez says:

    Weird, I don’t understand why it would work for other people but you… let’s take the troubleshooting off the blog post, please send me a direct email using the contact form and I’ll get back to you, I will like to see some screenshots of the error. Once we figure it out, I’ll update the post with a solution or diagnostic. Thanks Lisa!

  5. Leon says:

    Thanks for sharing. I had the same error but I checked windows/system32/inetsrv/config/applicationHost.config file. The file contains all the information you mentioned. Would you know what the issue would be in this case. Thanks.

  6. Darek says:

    This has worked for me. I’m so happy :))) You have no idea how much time I have spent trying to solve this… I’m no end grateful. You’re a real star!

  7. Anthony A says:

    Hello Alex,
    Were you able to resolve Lisa M’s issue? I’ve ran into this multiple times and my symptoms are very much like hers. Thanks!

    • Alex Gonzalez says:

      Hi Anthony, I think we checked group and individual level permissions. If you still have the issue, please send me an email and let’s bounce ideas offline. Cheers!

Leave a Reply